Belgium - System outage

Incident Report for Customs4trade

Resolved

Dear Customer,

This situation has been resolved, and the declarations are being processed as usual. We apologize for the inconvenience this disrupt may have caused.

Thank you again for your patience and understanding.
Posted Oct 13, 2025 - 21:05 CEST

Update

We are continuing to investigate this issue.
Posted Oct 13, 2025 - 17:31 CEST

Investigating

Dear Customer

We have noticed that your declarations for AES/IDMS are not being processed as usual. This matter is being investigated with a high priority.

More updates will follow soon.

Thank you for your patience.
Posted Oct 13, 2025 - 17:27 CEST
This incident affected: Belgium.