FR DELTA I/E EXPORT are not being processed

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 13:52 CET

Investigating

We noticed that French export declaration are not being processed. We are currently investigating the situation.
Posted Jan 09, 2026 - 10:39 CET
This incident affected: France.