Germany - Delay in processing by DE Customs

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 18:02 CET

Identified

Dear Customer

We have received notification that DE Customs is experiencing delays in processing declarations. We assure you that your declaration has been submitted by CAS and will move forward as soon as Customs authorities resolve the situation.
Posted Nov 14, 2025 - 12:52 CET
This incident affected: Germany.