System outage - HMRC UK

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Nov 02, 2025 - 09:18 CET

Identified

Dear Customer,

We are seeing that some UK declarations are not processed at the moment. We're in contact with UK customs to determine the root cause of this situation and will keep you updated.
Posted Nov 02, 2025 - 07:53 CET
This incident affected: Great Britain.