Delay in processing by NCTS P5

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 11:29 CEST

Identified

Dear Customer

We have received notification that NCTS P5 is experiencing delays in processing declarations. We assure you that your declaration has been submitted by CAS and will move forward as soon as Customs authorities resolve the issue

Since the NCTS P5 system update on August 27, 2025, we have noticed that certain declarations remain stuck with the "ACCEPTED" status and are not released after the statutory two-hour deadline.
These declarations must be followed up overnight by the competent CRC. Please note that the NCTS Helpdesk does not have the necessary resources to process these requests.
Below are the email addresses of the various CRCs, depending on the region involved:

📧 da.crc.antwerpen@minfin.fed.be
📧 da.crc.zaventem@minfin.fed.be
📧 da.crc.bierset@minfin.fed.be
Posted Aug 28, 2025 - 18:27 CEST
This incident affected: Belgium.