Delay in processing of BE declarations

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 12:06 CEST

Identified

Dear Customer

We are seeing that BE declarations (AES, iDMS, PLDA) are processed with a delay. We are investigating this situation with due priority and will keep you updated.
Posted Sep 11, 2025 - 10:53 CEST
This incident affected: Belgium.