Germany - ATLAS - Delay in processing

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 13:31 CET

Identified

Dear Customer

We have received notification that German Customs is experiencing delays in processing declarations. We assure you that your declaration has been submitted by CAS and will move forward as soon as Customs authorities resolve the situation.

If you have any questions, please contact German Customs authorities directly.
Posted Oct 29, 2025 - 02:59 CET
This incident affected: Germany.