DE - Unscheduled downtime

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted May 25, 2026 - 18:00 CEST

Investigating

Dear Customer

We are currently experiencing an unscheduled disruption affecting customs processing in Germany. Submissions and responses for import (EZA) and Suma procedures may be delayed or unavailable. Our team is actively monitoring the situation. We will provide updates as more information becomes available.

Incident start time: May 25, 2026 – 12:05 UTC (14:05 CEST)
Posted May 25, 2026 - 14:31 CEST
This incident affected: Germany.