GB - CDS - Scheduled maintenance (Acceptance environment)

Scheduled for Nov 11, 14:00 - 17:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 07, 2025 - 10:38 CET

Scheduled

Dear Customer

We have received the following information from Customs Authorities concerning a scheduled maintenance.

If you require assistance, please contact our Customer Support team via the ticket portal.

"
Posted Nov 06, 2025 - 11:19 CET
This scheduled maintenance affects: Great Britain.