Delay in processing of BE declarations

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 15:57 CET

Investigating

We are seeing that BE declarations (AES, iDMS, PLDA) are not getting released. We are investigating this situation with due priority and will keep you updated.
Posted Oct 30, 2025 - 11:41 CET
This incident affected: Belgium.