BE - System outage

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted 24 days ago. Apr 14, 2025 - 15:13 CEST

Investigating

Dear Customer

We have noticed that your declarations for EAS are not being processed as usual. This matter is being investigated with a high priority.

More updates will follow soon.

Thank you for your patience.
Posted 24 days ago. Apr 14, 2025 - 14:42 CEST
This incident affected: Belgium.