Processing issues - BE jurisdiction

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 09:20 CET

Identified

Dear Customer,

We noticed that some BE declarations are getting stuck in submitted. We're looking into this and checking the root cause with BE customs.
Posted Nov 20, 2025 - 08:22 CET
This incident affected: Belgium.