UK - CDS TDR (Test environment) incident

Incident Report for Customs4trade

Resolved

Hello,

We can confirm that the issue impacting the CDS Trader Dress Rehearsal Environment has now been resolved.
The service has been monitored and is operating as expected.
They apologise for any inconvenience caused.

Customer Support
Posted Nov 20, 2025 - 15:43 CET

Monitoring

Hello,

We are aware of an incident affecting the CDS Trader Dress Rehearsal Environment. This issue is currently being investigated.
We will keep our community informed as and when more information becomes available to us. If you have any queries, please contact the TDR Comms Team at: tdrcommunications@hmrc.gov.uk

Kind regards,

Customer Support
Posted Nov 20, 2025 - 14:24 CET
This incident affected: Great Britain.