Delay in processing by CDS UK

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 16:59 CEST

Identified

Dear Customer

We have received notification that CDS is experiencing delays in processing CCS messages. We assure you that your declaration has been submitted by CAS and will move forward as soon as Customs authorities resolve the issue.

If you have any questions, please contact British Customs authorities directly.
Posted Jun 06, 2025 - 14:12 CEST
This incident affected: Great Britain.