Delay in processing by AES BE

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 10:45 CEST

Identified

Dear Customer,

We have received notification that AES BE is experiencing delays in processing declarations. We assure you that your declaration has been submitted by CAS and will move forward as soon as Customs authorities resolve the issue.

If you have any questions, please contact Belgian Customs authorities directly.
Posted Apr 18, 2025 - 08:54 CEST
This incident affected: Belgium.