GB - NCTS - Customs system outage

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 09:00 CEST

Identified

Dear Customer

We noticed that NCTS GB is experiencing an outage. Declarations sent to this system are receiving SendingErrors. We have not received official confirmation regarding this outage, but we are trying to communicate with customs to receive more information.

If you have further questions, please contact HMRC directly.
Posted Apr 07, 2026 - 16:18 CEST
This incident affected: Great Britain.