BE - IDMS - Customs system outage

Incident Report for Customs4trade

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 08:14 CEST

Identified

Dear Customer

We have received confirmation that FINDA — the financial backend system used by Belgian Customs (IDMS) to verify customer accounts and deferred payment methods — is currently unavailable.

As a result, declarations submitted via CAS may return a Customs Error while this verification cannot be completed by Customs. This is a technical issue on the Belgian Customs side, not a data issue in your declaration.

At this time, the only possible action is to wait and resubmit the affected declarations once the service is restored. Please note that the emergency procedure is not authorized for this incident.

We will keep you informed as soon as further updates are available. If you have further questions, please contact Belgian Customs authorities directly.
Posted Aug 05, 2026 - 14:39 CEST
This incident affected: Belgium.